Partial outage on Ghost(Pro)
Resolved·Partial outage

We have continued to monitor everything whilst completing internal work to ensure all systems have been returned to full functionality. We are confident that everything has returned to normal and the incident is fully resolved.

We will be following up with a full post mortem soon.

Fri, Aug 1, 2025, 05:13 PM
(1 day ago)
·
Affected components
Ghost(Pro)
Updates

Resolved

We have continued to monitor everything whilst completing internal work to ensure all systems have been returned to full functionality. We are confident that everything has returned to normal and the incident is fully resolved.

We will be following up with a full post mortem soon.

Fri, Aug 1, 2025, 05:13 PM

Monitoring

Normal service has been restored. All sites are online and functioning normally.

We will continue to monitor systems very closely for some time before declaring the incident fully resolved.

Fri, Aug 1, 2025, 01:05 PM(4 hours earlier)

Identified

The deployment is taking much longer than expected. We've begun the process of switching to new infrastructure instead. Our engineers are still working on resolving this as quickly as possible.

Fri, Aug 1, 2025, 12:51 PM(13 minutes earlier)

Identified

A fix is being deployed for the root cause of the incident. This should take a further 30minutes to complete, at which point, we should be able to bring sites back online much faster than we have been able to.

Fri, Aug 1, 2025, 11:43 AM(1 hour earlier)

Identified

We have determined a root cause for the incident and are working to understand and resolve the underlying problem.

Meanwhile sites are continuing to come back online and work on additional infrastructure is still underway.

Fri, Aug 1, 2025, 10:49 AM(54 minutes earlier)

Identified

Sites are continuing to come back online. Work to deploy additional infrastructure as a contingency is also continuing. We're bringing more engineers online to ensure we can continue to work on this as fast as possible.

Fri, Aug 1, 2025, 09:44 AM(1 hour earlier)

Identified

Sites are continuing to come back online, and we're in the process of deploying additional infrastructure as a contingency should we need it. Our engineers are working as quickly as they can to resume normal service

Fri, Aug 1, 2025, 08:54 AM(49 minutes earlier)

Identified

Our fix has been implemented and sites are now starting to come back online in batches. Thanks for your patience

Fri, Aug 1, 2025, 08:11 AM(42 minutes earlier)

Identified

We're making progress, and still working on deploying configuration changes to resolve the ongoing database connection issues. We are temporarily placing a number of sites into maintenance mode to help bring them back online.

Fri, Aug 1, 2025, 07:37 AM(34 minutes earlier)

Identified

We've identified the cause of persistent database locks, and we've brought more engineers online who are working on deploying a change to our configuration to resolve the issue.

Fri, Aug 1, 2025, 06:39 AM(58 minutes earlier)

Identified

We've seen some small improvement and recovery as a result of mitigation work, but our DB cluster is still struggling. The team is still working on it and we'll continue to share updates as we make progress.

Fri, Aug 1, 2025, 05:25 AM(1 hour earlier)

Identified

The team is still working hard on mitigating the issues we're experiencing with the database cluster. We'll continue to share updates here as we make progress

Fri, Aug 1, 2025, 04:47 AM(38 minutes earlier)

Identified

We're continuing to see high levels of load on one of our primary database clusters, and the team is working as quickly as they can to mitigate the issue.

Fri, Aug 1, 2025, 04:20 AM(26 minutes earlier)

Identified

We're continuing to investigate the cause of the intermittent issues impacting our database cluster. We'll update when we have more in the next 30 minutes.

Fri, Aug 1, 2025, 03:48 AM(31 minutes earlier)

Identified

We've identified a performance issue on one of our database clusters which is causing intermittent issues for some customers. The team is actively working on a fix

Fri, Aug 1, 2025, 03:14 AM(34 minutes earlier)

Investigating

We're currently investigating a high number of errors on Ghost(Pro). Users may see timeouts loading pages and updating or publishing content through Ghost Admin.

Fri, Aug 1, 2025, 02:56 AM(17 minutes earlier)
Powered by