Degraded cache clearing
Resolved·Partial outage

We’re happy to let you know that the cache clearing issue has been fixed! All users should be able to see the new content they publish without any further problems.

Fri, Oct 10, 2025, 09:06 PM
(2 weeks ago)
·
Affected components
Ghost(Pro) Websites
Updates

Resolved

We’re happy to let you know that the cache clearing issue has been fixed! All users should be able to see the new content they publish without any further problems.

Fri, Oct 10, 2025, 09:06 PM

Monitoring

We wanted to provide you with an update regarding the timeout errors we were experiencing when attempting to purge paths for our customers. We have identified the root cause of the issue and are currently monitoring the situation.

Fri, Oct 10, 2025, 08:45 PM(21 minutes earlier)

Investigating

We are continuing our investigation into the cache clearing issue that has affected a small subset of users. Our team is actively taking internal actions to address the problem.

Fri, Oct 10, 2025, 08:12 PM(32 minutes earlier)

Investigating

We are currently experiencing an issue with our cache clearing process, which may affect a small subset of users. Some users may not be able to see new content they publish. We are actively investigating the matter and working to resolve it as quickly as possible.

Fri, Oct 10, 2025, 06:46 PM(1 hour earlier)