Reduced performance on Ghost(Pro)
Resolved·Degraded performance

All services are working normally

Wed, Jan 7, 2026, 12:35 PM
(2 weeks ago)
·
Affected components
Ghost(Pro) Websites
Ghost(Pro) Admin
Updates

Resolved

All services are working normally

Wed, Jan 7, 2026, 12:35 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Wed, Jan 7, 2026, 10:48 AM(1 hour earlier)

Identified

We've identified the cause of the degraded performance and are working to resolve the issue.

Wed, Jan 7, 2026, 10:45 AM

Investigating

Some users are currently experiencing difficulties with accessing and logging into their sites on Ghost(Pro). We are looking into this issue now and hope to have everything back to normal shortly.

Wed, Jan 7, 2026, 10:41 AM