Degraded functionality for offers on Ghost(Pro)
Resolved·Degraded performance

All services are working normally again, thanks for your patience.

Mon, Jan 26, 2026, 08:16 PM
(21 hours ago)
·
Affected components
Ghost(Pro) Admin
Updates

Resolved

All services are working normally again, thanks for your patience.

Mon, Jan 26, 2026, 08:16 PM

Identified

We're in the process of rolling the fix out to all sites.

Mon, Jan 26, 2026, 07:44 PM(32 minutes earlier)

Identified

We've identified the issue and are working on a fix.

Mon, Jan 26, 2026, 07:14 PM(30 minutes earlier)

Investigating

We are investigating an issue with degraded functionality for offers. Our on-call team is actively working on it, and we'll share more information here shortly.

Mon, Jan 26, 2026, 06:46 PM(27 minutes earlier)