This incident is now resolved. Posts should now publish at the correct scheduled time.
Posts that were scheduled to be published between 10:00 UTC and 21:00 UTC on 2 April 2026 may not have been published at the intended time, but they should have been published during the rollout of the fix.
Resolved
This incident is now resolved. Posts should now publish at the correct scheduled time.
Posts that were scheduled to be published between 10:00 UTC and 21:00 UTC on 2 April 2026 may not have been published at the intended time, but they should have been published during the rollout of the fix.
Monitoring
A fix for the issue has been identified and is currently being rolled out across Ghost(Pro)
Identified
We have identified the cause of the issue and are working on a resolution
Investigating
We’re still investigating the cause of scheduled posts not being published. Our on-call team is actively working on it, and we’ll share more information here as soon as we have an update.
Investigating
Some customers are experiencing issues with scheduled posts not being published. We’re currently investigating the cause, and our on-call team is actively working on it.