·
Norma; service has resumed
Resolved
Monitoring
Custom domains and SSL provision is back to normal
Identified
It is taking longer than usual to issue a certificate for a new custom domains
Our upstream SSL provider is investigating this issue