Resolved
Posts and pages are updating as normal again.
Identified
Most updates appear to be going through quickly now. We're working with our upstream provider to resolve this issue.
Investigating
Cache invalidation issues are preventing pages from updating. New published pages are not appearing on the homepage, and updated posts are not reflected.