Resolved
Image loading is back to normal.
Monitoring
We've put a fix in place and are monitoring the results.
Identified
We've identified the problem and are rolling out a fix.
Investigating
Images on Ghost(Pro) websites are currently experiencing degraded performance and may not load correctly. We're looking into this issue and hope to have everything back to normal shortly.